Bilgisayar-Bilişim Teknolojileri
Ana Sayfa
Bilişim Teknolojileri Forumu Son Konuları
24 Saat
Bilişim Teknolojileri - Formatör - Bilgisayar Öğretmeni Kayıt
Kayıt Olun
iletişim
iletişim
Detaylı Arama
Arama
Yeni Konu Aç
Yeni Konu Aç

xoops foto ekleme sorunu

Konu, 'Xoops' kısmında ilkerkorkusuz20 tarafından paylaşıldı.


  1. ilkerkorkusuz20

    ilkerkorkusuz20 Site Gezgini

    Kayıt:
    3 Ekim 2007
    Mesajlar:
    30
    Beğeni:
    0
    Arkadaşlar öğretmen fotolarını eklemede bi problem yok ama foto albüme foto ekliyorum dosya eklediğim görünüyo ama resim görünmüyo yapmam gereken özel bi ayar mı var yada resim dosyalarının uzantısı mı değişik olacak yardımlarınızı bekliyorum.
    Herkese İyi Çalışmalar...
     
  2. omerbilgin

    omerbilgin Seçkin Üye Seçkin Üye

    Kayıt:
    11 Ocak 2008
    Mesajlar:
    562
    Beğeni:
    3
    Foto albüme dosya eklerken dikkat edilmesi gereken kurallar:
    1- Yazma izinleri düzgün ayarlanmışmı?
    2- dosya adlarında türkçe karakter ve boşluk kullanmayın
    3- Nadirende olsa bazen JPG ile jpg arasında mantıksızda olsa ayrım yapıyor sanıyorum. BAzı programların jpg formatıyla yğklendiğinde görünmüyor alıp farklı kaydediyorum jpg olarak ozaman yükleniyor. Nedenini anlamasamda çözümü bu şekilde.

    Bunlarda işe yaramazsa bana bilgi veriniz.
     
  3. ilkerkorkusuz20

    ilkerkorkusuz20 Site Gezgini

    Kayıt:
    3 Ekim 2007
    Mesajlar:
    30
    Beğeni:
    0
    Hocam yazma izinleri videoda belirtildiği şekilde ayarlanmış durumda
    Dosya isimlerinde Türkçe karakter ve boşluk yok
    Aynı zamanda ana sayfadaki foto albümüzden bloğunda da resimler görünmüyo ilginize teşekkür ediyorum.
    Foto albümün birkaç resmini gönderiyorum panelde ve anasayfadaki görüntüsünden.
    İyi Çalışmalar..
     

    Ekli Dosyalar:

  4. omerbilgin

    omerbilgin Seçkin Üye Seçkin Üye

    Kayıt:
    11 Ocak 2008
    Mesajlar:
    562
    Beğeni:
    3
    Hocam aşağıdaki yerlerin yazma izinlerini kontrol edermisiniz?

    siteadi.com/uploads 777 olacak
    siteadi.com/uploads/tadgallery/ 777 olacak
    ve tadgallery klasörünün içindeki tüm klasörler 777 olacak

    11.jpg şeklinde bir resmi yuklemeyi deneyin isim problemi olacakmı test etmek için.

    Eğer bunlar düzgün ve hala çalışmıyorsa modülü kaldırıp tekrar kurun.
     
  5. ilkerkorkusuz20

    ilkerkorkusuz20 Site Gezgini

    Kayıt:
    3 Ekim 2007
    Mesajlar:
    30
    Beğeni:
    0
    Hocam ilginiz için çok teşekkür ederim, foto albüm modülünü yeniden kurmayı anlatabilir misiniz
    İyi Çalışmalar..
     
  6. omerbilgin

    omerbilgin Seçkin Üye Seçkin Üye

    Kayıt:
    11 Ocak 2008
    Mesajlar:
    562
    Beğeni:
    3
  7. ilkerkorkusuz20

    ilkerkorkusuz20 Site Gezgini

    Kayıt:
    3 Ekim 2007
    Mesajlar:
    30
    Beğeni:
    0
    Hocam foto albüm modülünü kaldırıp yeniden kurdum. Dosya başarıyla yüklendi diyo ama fotoları gene göremiyorum. İlginize teşekkürler..
    İyi Çalışmalar...
     
  8. aakcakaza

    aakcakaza Hiperaktif Üye Hiperaktif

    Kayıt:
    23 Eylül 2007
    Mesajlar:
    4.470
    Beğeni:
    36
    Hocam siteyi tekrar kurmayı deneyin.
     
  9. omerbilgin

    omerbilgin Seçkin Üye Seçkin Üye

    Kayıt:
    11 Ocak 2008
    Mesajlar:
    562
    Beğeni:
    3
    Hocam bunlarıda yaptıysanız ve bu hata düzelmediyse muhtemelen sunucuyla alakalı bir sorun vardır. Aynı benzer hatayla biri daha gelmişti. Ben birebir kurulum yaptım sunucusuna çözüm olmadı.
    Sunucu firmanızla bir görüşün. Hostunuzun yetkileri sınırlı sanırım.
     
  10. ilkerkorkusuz20

    ilkerkorkusuz20 Site Gezgini

    Kayıt:
    3 Ekim 2007
    Mesajlar:
    30
    Beğeni:
    0
    Arkadaşlar hosting hizmeti aldığım yerin müşteri temsilcisine izinlerle ilgili bi sorun olduğunu belirten bir mail gönderdim. Bana gönderdiği cavabı buraya kopyaladım.

    Değerli müşterimiz,

    Burada ben sunucu ile alakalı bir sorun göremiyorum.

    /uploads klasörünün içerisine 3 Ekimde bir .htaccess dosyası yüklenmiş bu .htaccess dosyasında gördüğüm kadarıyla site üzerinden illegal bir hack girişi yapılabilmesi için yükleme yapılmış, tabi güvenlik olduğu için sunucularda bir işlem yapılamamış. Yapılmak istenilen alınan güvenliği devre dışı bırakıp kendi yükledikleri yazılımı çalıştırmak tabiki böyle bir güvenlik tehtidi oluştuğunda otomatik olarak sunucu engeller .htaccess dosyasını kaldırı ve klasör ayarlarını tekrar eski hali olan 755 yaparsanız çalışır. Sunucularımızda güvenlik önlemi nedeniyle yetkileri değiştirdiğinizde site çalışmaz 777 yaparsanız bozulur dosyalar 644 klasörler ise 755 olmalıdır.
     
  11. omerbilgin

    omerbilgin Seçkin Üye Seçkin Üye

    Kayıt:
    11 Ocak 2008
    Mesajlar:
    562
    Beğeni:
    3
    Hocam .htacess dosyasını silin sorun düzelir diyorlar. Bu sunucu windows mu? Linuxmü acaba?
    Bizim xoops sisteminin orjinal dosyalarında uploads/.htacess dosyası mevcuttur.

    İndiirp pcnize açtığınızda aşağıdaki kodlar dışında kod görüyormusunuz?

    # secure directory by disabling script execution
    AddHandler cgi-script .php .pl .py .jsp .asp .htm .shtml .sh .cgi .php5 .php4 .php3 .phps
    Options -ExecCGI -Indexes

    Bunların dışında kod varsa hakikaten hack girişimi olabilir. Onuda sunucunun bahsettiği yazma ayarlarını yaparsanız çözebilirisiniz.
    Bizim sunucumuzda bu güne kadar böyle bir problem görmediğim için bişey diyemiyorum.
     
  12. omerbilgin

    omerbilgin Seçkin Üye Seçkin Üye

    Kayıt:
    11 Ocak 2008
    Mesajlar:
    562
    Beğeni:
    3
    Hocam olayı daha iyi aydınlatmak için size ücretsiz bir host verelim 1 haftalık girin kurcalayın aynı kurulumu yapın bakalım bu şekilde hata olacakmı.
    İrtibat için bana 530767801 nolu telefondan ulaşabilirisniz.
     
  13. ilkerkorkusuz20

    ilkerkorkusuz20 Site Gezgini

    Kayıt:
    3 Ekim 2007
    Mesajlar:
    30
    Beğeni:
    0
    Hocam ilginiz için teşekkür ederim akşam eve gidince siteyi kaldırıp yeniden kuracağım gene olmazsa sizin hostunuzundan kurulum yapıp deneyelim.
    İyi Çalışmalar...
     
  14. ilkerkorkusuz20

    ilkerkorkusuz20 Site Gezgini

    Kayıt:
    3 Ekim 2007
    Mesajlar:
    30
    Beğeni:
    0
    Hocam siteyi tekrar kurdum foto albüm gene aynı hiç resim görüntülenmiyo
     
  15. omerbilgin

    omerbilgin Seçkin Üye Seçkin Üye

    Kayıt:
    11 Ocak 2008
    Mesajlar:
    562
    Beğeni:
    3
    Yarın size bir host verelim hocam bi deneyin.
     
  16. ilkerkorkusuz20

    ilkerkorkusuz20 Site Gezgini

    Kayıt:
    3 Ekim 2007
    Mesajlar:
    30
    Beğeni:
    0
    Hocam centoshosta üye oldum
    dnsleri de değiştirdim
     
  17. uragan06

    uragan06 Seçkin Üye Seçkin Üye

    Kayıt:
    1 Eylül 2008
    Mesajlar:
    347
    Beğeni:
    4
    hocam aynı sorunu bende yaşıyorum.Host yazma izinleri tamam ama fotoğraf yükleyemiyorum.tdgallery modülü ile ilgili olabilir mi?
     
  18. okadda

    okadda Seçkin Üye Seçkin Üye

    Kayıt:
    12 Ekim 2007
    Mesajlar:
    502
    Beğeni:
    3
    sağlam horrt olmuş......... :D
    xoops son sürüm stabil değil galiba .
     

Sayfayı Paylaş /bbnetsosyal